From an MSNBC "browser check" while using Safari on OS X:

Message boards - unsupported web client

This feature requires a more recent version of Microsoft Internet Explorer
or Mozilla Firefox. To download the latest version of Microsoft Internet Explorer,
visit the Internet Explorer Web

Thanks. I like the Firefox nod, so that you partially quiet the geek quotient, but for J. Q. Apple User of The One Button Mice, well, too bad.

Curiously, the same error message pops up when you use Explorer 5.2.3 for the Mac, the last version before MS dropped support. I'm not sure I'm going to find much of an answer at the IE Web site. I'm going to call that link with the implicit promise of fixing the posting problem a bit underhanded. As if msnbc hasn't heard of Safari.