The Google Talk Gadget requires Adobe Flash Player version 8 or higher.
You can install the player here.

To complete the installation, quit all running instances of your browser.

I've been impressed with the gmail web interface, and based on those experiences figured they were bright enough to do most anything they wanted without leaving the dhtml playground. Turns out with the "official" Google Chat widget on iGoogle uses Flash, as quoted, above. That's interesting... Wonder why they sold out and what other Google interfaces use Flash.