The variable name 'bLocalMode' begins with a prefix that looks like Hungarian notation.

Oh noes!  Not Hungarian notation.  Thanks for stopping my build, Style Cop!

Seriously, there isn't a single naming convention that circumvents the weaknesses of Hungarian notation "Oh no, you can put a string in a variable that calls itself an int!"  Well, at least there was intention.  How many times has, "temp_calendar" actually had a calendar id at one moment and the object in another or, worse, has something completely unrelated "biding time" in that variable?  There's nothing about that name that requires the tie between mnemonic and meaning.

How about this example from ExtJS where I note that we have "a programmer more interested in showing off than creating self-commenting code"?  Great variable names like "f" are used to represent a number of different concepts.  As I concluded then, "And let's just say that variables named r,f,fi,fl,v,g are bad enough before they're reused without even a passing regard for typing."  Tell me Hungarian wouldn't help there.

Say what you want about the Hungarian Notationists.  At least it's an ethos, dude.

Labels: , ,